Non notée
CVE-2026-77147 Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Syncope 4.1 | 4.1.0-M0 → 4.1.2 | Pas de correctif indiqué |
| Apache Syncope 4.0 | 4.0.0-M0 → 4.0.7 | Pas de correctif indiqué |
| Apache Syncope 3.0 | 3.0.0-M0 → 3.0.16 | Pas de correctif indiqué |
Autres CVE de Apache Syncope
Les 45 CVE de Apache Syncope →
CVE-2026-114364
Apache Syncope: SQL injection via unsanitized opEvent in Audit Events search
Non notée
CVE-2026-113687
Apache Syncope: RCE via ProcessGroovyMethodsSandbox bypass
Non notée
CVE-2026-113511
Apache Syncope: Delegated administration boundaries can be bypassed for Realm update
Non notée
CVE-2026-110535
Apache Syncope: AuthProfile value escalation via self-service update
Non notée