5.4
Moyenne
CVE-2026-1927 The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due…
Description
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the greenshift_app_pass_validation() function in all versions up to, and including, 12.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve global plugin settings including stored AI API keys and modify plugin settings, including the injection of arbitrary web scripts via the 'custom_css' value (stored XSS). NOTE: This vulnerability was partially patched in version 12.6.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Greenshift – animation and page builder blocks 12.6 | premières → 12.6 | Pas de correctif indiqué |
Autres CVE de Greenshift – animation and page builder blocks
Les 22 CVE de Greenshift – animation and page builder blocks →
CVE-2026-119218
Greenshift <= 13.2.2 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment Author URL via Interaction Layer attach-attribute to Counter data-prefix
5.4
Moyenne
CVE-2026-120520
Greenshift <= 13.2.2 - Unauthenticated Sensitive Information Exposure in Nested {{COOKIE:}} Placeholder via {{GET:}} Parameter
5.3
Moyenne
CVE-2026-107629
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site…
5.4
Moyenne
CVE-2026-107627
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site…
5.4
Moyenne