2.2
Faible
CVE-2023-5870 Postgresql: role pg_signal_backend can signal certain superuser processes.
Description
A flaw was found in PostgreSQL involving the pg_cancel_backend role that signals background workers, including the logical replication launcher, autovacuum workers, and the autovacuum launcher. Successful exploitation requires a non-core extension with a less-resilient background worker and would affect that specific background worker only. This issue may allow a remote high privileged user to launch a denial of service (DoS) attack.
Détail CVSS 3.1
Vecteur CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:LExploitable à distance par le réseau, avec un compte administrateur et sans action d’un utilisateur ; l’impact sur les données ou le service reste limité.
- Vecteur d’attaque
- Réseau
- Complexité
- Élevée
- Privilèges requis
- Élevés
- Interaction
- Aucune
- Portée
- Inchangée
- Confidentialité
- Aucun
- Intégrité
- Aucun
- Disponibilité
- Faible
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Red Hat Advanced Cluster Security 4.2 4.2 | premières → < 4.2.4-7 | 4.2.4-7 |
| Red Hat Enterprise Linux 8 | Versions non publiées | |
| Red Hat Enterprise Linux 8.2 Advanced Update Support 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Telecommunications Update Service 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Update Services for SAP Solutions 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Telecommunications Update Service 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.6 Extended Update Support 8060020231128165328 | premières → < 8060020231128165328.ad008a3a | 8060020231128165328.ad008a3a |
Afficher les 10 autres branches Masquer les 10 autres branches
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Red Hat Enterprise Linux 8.8 Extended Update Support 8080020231113134015.63 | premières → < 8080020231113134015.63b34585 | 8080020231113134015.63b34585 |
| Red Hat Enterprise Linux 9 | Versions non publiées | |
| Red Hat Enterprise Linux 9.0 Extended Update Support | Versions non publiées | |
| Red Hat Enterprise Linux 9.2 Extended Update Support 9020020231115020618 | premières → < 9020020231115020618.rhel9 | 9020020231115020618.rhel9 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | Versions non publiées | |
| RHACS-3.74-RHEL-8 3.74 | premières → < 3.74.8-9 | 3.74.8-9 |
| RHACS-4.1-RHEL-8 4.1 | premières → < 4.1.6-6 | 4.1.6-6 |
| Red Hat Enterprise Linux 6 | Versions non publiées | |
| Red Hat Enterprise Linux 7 | Versions non publiées | |
| Red Hat Software Collections | Versions non publiées |
Autres CVE de Red Hat Advanced Cluster Security 4.2
Les 5 CVE de Red Hat Advanced Cluster Security 4.2 →
CVE-2023-4958
In Red Hat Advanced Cluster Security (RHACS), it was found that some security related HTTP headers were missing,…
6.1
Moyenne
CVE-2023-5869
Postgresql: buffer overrun from integer overflow in array modification
8.8
Élevée
CVE-2023-5868
Postgresql: memory disclosure in aggregate function calls
4.3
Moyenne
CVE-2023-39417
Postgresql: extension script @substitutions@ within quoting allow sql injection
7.5
Élevée