Skip to content
Not rated

CVE-2026-30911 Apache Airflow versions 3.1.0 through 3.1.7 missing authorization vulnerability in the Execution API's Human-in-the-Loop…

Description

Apache Airflow versions 3.1.0 through 3.1.7 missing authorization vulnerability in the Execution API's Human-in-the-Loop (HITL) endpoints that allows any authenticated task instance to read, approve, or reject HITL workflows belonging to any other task instance. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 3.1 3.1.0 → < 3.1.8 3.1.8
The 153 CVEs of Apache Airflow →
Track this CVE