4.3
Medium
CVE-2023-5868 Postgresql: memory disclosure in aggregate function calls
Description
A memory disclosure vulnerability was found in PostgreSQL that allows remote users to access sensitive information by exploiting certain aggregate function calls with 'unknown'-type arguments. Handling 'unknown'-type values from string literals without type designation can disclose bytes, potentially revealing notable and confidential information. This issue exists due to excessive data output in aggregate function calls, enabling remote users to read some portion of system memory.
CVSS 3.1 detail
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitable remotely over the network, with an ordinary account and without any user action; the impact on data or service is limited.
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- Interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat Advanced Cluster Security 4.2 4.2 | earliest → < 4.2.4-7 | 4.2.4-7 |
| Red Hat Enterprise Linux 8 | Versions not published | |
| Red Hat Enterprise Linux 8.2 Advanced Update Support 8020020231128165246.4 | earliest → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Telecommunications Update Service 8020020231128165246.4 | earliest → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Update Services for SAP Solutions 8020020231128165246.4 | earliest → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020231127154806.522 | earliest → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Telecommunications Update Service 8040020231127154806.522 | earliest → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 8040020231127154806.522 | earliest → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.6 Extended Update Support 8060020231128165328 | earliest → < 8060020231128165328.ad008a3a | 8060020231128165328.ad008a3a |
Show the 10 other branches Hide the 10 other branches
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat Enterprise Linux 8.8 Extended Update Support 8080020231113134015.63 | earliest → < 8080020231113134015.63b34585 | 8080020231113134015.63b34585 |
| Red Hat Enterprise Linux 9 | Versions not published | |
| Red Hat Enterprise Linux 9.0 Extended Update Support | Versions not published | |
| Red Hat Enterprise Linux 9.2 Extended Update Support 9020020231115020618 | earliest → < 9020020231115020618.rhel9 | 9020020231115020618.rhel9 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | Versions not published | |
| RHACS-3.74-RHEL-8 3.74 | earliest → < 3.74.8-9 | 3.74.8-9 |
| RHACS-4.1-RHEL-8 4.1 | earliest → < 4.1.6-6 | 4.1.6-6 |
| Red Hat Enterprise Linux 6 | Versions not published | |
| Red Hat Enterprise Linux 7 | Versions not published | |
| Red Hat Software Collections | Versions not published |
Other CVEs of Red Hat Advanced Cluster Security 4.2
The 5 CVEs of Red Hat Advanced Cluster Security 4.2 →
CVE-2023-4958
In Red Hat Advanced Cluster Security (RHACS), it was found that some security related HTTP headers were missing,…
6.1
Medium
CVE-2023-5870
Postgresql: role pg_signal_backend can signal certain superuser processes.
2.2
Low
CVE-2023-5869
Postgresql: buffer overrun from integer overflow in array modification
8.8
High
CVE-2023-39417
Postgresql: extension script @substitutions@ within quoting allow sql injection
7.5
High