Not rated
CVE-2026-53421 Improper Isolation or Compartmentalization vulnerability in Apache Syncope
Description
Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Syncope 4.1 | 4.1.0-M0 → 4.1.1 | No fix stated |
| Apache Syncope 4.0 | 4.0.0-M0 → 4.0.6 | No fix stated |
| Apache Syncope 3.0 | 3.0.0-M0 → 3.0.16 | No fix stated |
Other CVEs of Apache Syncope
The 45 CVEs of Apache Syncope →
CVE-2026-114364
Apache Syncope: SQL injection via unsanitized opEvent in Audit Events search
Not rated
CVE-2026-113687
Apache Syncope: RCE via ProcessGroovyMethodsSandbox bypass
Not rated
CVE-2026-113511
Apache Syncope: Delegated administration boundaries can be bypassed for Realm update
Not rated
CVE-2026-110535
Apache Syncope: AuthProfile value escalation via self-service update
Not rated